Investigating Partial Outage
Incident Report for OpenWater
Resolved
Normal operations restored.
Posted over 2 years ago. Oct 10, 2016 - 10:45 EDT
Investigating
We are currently investigating an outage for a portion of our customers who are unable to access the OpenWater Platform.
Posted over 2 years ago. Oct 10, 2016 - 10:32 EDT