Longer Page Load Times
Incident Report for OpenWater
Resolved
Page load times have returned to normal speed.
Posted over 2 years ago. Feb 08, 2017 - 12:35 EST
Investigating
We are currently investigating slower than normal page load times on the general OpenWater platform.
Posted over 2 years ago. Feb 08, 2017 - 10:56 EST