Widespread Network Issues
Incident Report for OpenWater
Resolved
This incident has been resolved.
Posted Jul 17, 2020 - 19:52 EDT
Monitoring
We have set the status as minor as we have gotten reports from our customers across the US/Canada that they are able to return with fast access.
Posted Jul 17, 2020 - 17:38 EDT
Update
The OpenWater platform is back up and the widespread outage seems to be mitigated, however as nearly every major website was taken down at the same time (source: DownDetector.com) we will continue to report and monitor.

Next Update 7:30 PM US eastern unless there is another significant incident.
Posted Jul 17, 2020 - 17:37 EDT
Update
We are continuing to investigate this issue.
Posted Jul 17, 2020 - 17:23 EDT
Investigating
There are widespread outage reports across the Internet at the moment. We will post updates here at least once per hour.
Posted Jul 17, 2020 - 17:21 EDT
This incident affected: General Platform.