Slow load times
Incident Report for OpenWater
Resolved
This incident has been resolved.
Posted about 1 year ago. Apr 26, 2018 - 14:28 EDT
Monitoring
Speeds have returned to normal. We are monitoring.
Posted about 1 year ago. Apr 26, 2018 - 11:30 EDT
Investigating
We are currently investigating reports of slow load times on OpenWater pages
Posted about 1 year ago. Apr 26, 2018 - 11:17 EDT
This incident affected: General Platform.