Slow load times on main platform
Incident Report for OpenWater
Resolved
This incident has been resolved.
Posted Oct 16, 2019 - 10:54 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Oct 16, 2019 - 10:39 EDT
Investigating
We are currently investigating this issue.
Posted Oct 16, 2019 - 10:06 EDT
This incident affected: General Platform.